Avatar

Zvažte možnost registrace, zatím jste zde jako
HOST

sp_LogInOutPřihlásit sesp_Registration Registrovat
No permission to create posts
RSS

Toshiba Satelite PRO 420CDT

08/08/2014 - 11:13
Avatar
Springy

Včera jsem Toshibu po dlouhé době znovu zapnul a čekalo mně nemilé překvapení. Notebook hlásil problém s cmos baterií a ani nereagoval na stisk F1, který by ho měl přepnout do biosu. Tak jsem se dal do rozebírání,  abych zjistil co a jak a zjistil jsem zajímavou věc. Po odendání na mě koukaly baterie 2. Jedna ze 3 malých článků 3.6V, 30mAh a druhá ze 6 větších článků 7.2V, 110! mAh. Pátral jsem, proč má notebook baterie 2 a zjistil jsem, že jedna by měla být pro cmos a druhá pro cmos ram (nevím, která je která). Nemáte někdo podobný notebook? Nevím kterou mám vyměnit. Ta menší je mrtvá, říkal známý ze servisu, a dá se sehna na ebay za 200Kč. Tu větší jsem nikde nenašel a teď jsem zjistil, že vytekla a konektor na deskce je zoxidovaný... Takže notebook asi levně neopravím, ach jo.

Tak ta velká baterie je ta pro cmos RAM. Ale na tom webu píšou, že je Ni-Cd a v notebooku byla Ni-MH. Na ebay jsem našel tuto vizuálně stejnou, ale s menší kapacitou.

08/08/2014 - 12:40
Avatar
Prague

Není ta velká spíš pro zálohování RAM v režimu spánku? Některé starší notebooky uměly ten fígl, že jsi uspal notebook, vyhodil hlavní vybitou baterii, dal tam jinou plně nabitou a zase jsi to probudil a fungoval normálně dál, RAM baterie  udržela obsah RAMky i několik minut bez potřeby baterie hlavní. V době kdy z pomalého notebookového disku bootovaly Windows 95 i pět minut, dalších pět se načítala plocha a ještě jednou pět se spouštěly programy to mělo velký význam. Pokud to je na tenhle účel a ty to nebudeš potřebovat, měl by notebook běžet i bez té baterie, stojí to za zkoušku.

08/08/2014 - 12:44
Avatar
Springy

Super! Děkuju! Objednám tu menší CMOS baterii a mezitím se zkusím zbavit těch reziduí na desce. Kéž by to pak fungovalo!

08/08/2014 - 14:13
Avatar
LubikCZ

Springy napsal(a)
Super! Děkuju! Objednám tu menší CMOS baterii a mezitím se zkusím zbavit těch reziduí na desce. Kéž by to pak fungovalo!

Něco k těm reziduím, držím palce ;)

https://www.high-voltage.cz/forum/pc/cisteni-zakladnich-desek-graf-karet-atd/

Každý počítač je hloupý nebo chytrý pouze tak, jako jeho majitel.

11/08/2014 - 20:04
Avatar
Springy

Tak jsem objednal baterii a mezitím jsem vyčistil konektory od zeleného hnusu. Dále jsem vyndal co šlo,  konektory pročistil kontakt sprejem a pres víkend nechal jednotlivé desky vysušit a odpočinout si :). Dneska jsem se pustil do kompletace. Kupodivu jsem to zase složil dohromady a nic mi nescházelo ani nepřebívalo :). Pro jistotu jsem do notebooku dal nazpět původní disk a pak ho zapnul. Naběhl :). Po informaci, že detekoval chybu cmos baterie jsem se konečně stiskem F1 dostal do biosu (notebook detekuje 24MB RAM, Pentium 100 MHz...). Po stisku Esc jsem opustil bios bez uložení nastavení a notebook začal bootovat do Windows 98 - hurá!

Pozitiva:

1) Funguje to i po mém, nebo právě po mém zásahu :). 2) Displej je docela v pohodě na 18 let starý stroj, zaplať Pán Bůh že je Toshiba CDT a má tedy TFT displej. 3) Zvukový chip je ESS, takže jak Sledge psal ve svém článku,  s kompatibilitou by neměl být problém. 4) Trafo je integrované v notebooku, k připojení do el. sítě stačí kabel od rádia :D. 5) Po 2 hoďkách nabíjení noťas zvládne nabootovat do winů jen na baterii.

Ale vždycky je tu nějaký ale:

Asi jsem lama a od dob hraní pod dosem jsem vsechno zapoměl. Nebyl jsem schopný spustit jedinou hru pod dosem tak, aby byla se zvukem. Zvukovka pod windowsy funguje, takže zde by neměl být problém, doufám. Nikdy nevím, kterou zvukovku pro kterou hru vybrat :). Některé hry po mně chtěly takové ty IRQ a tak. V biosu jsem zjistil, že zvukový adaptér má tyto údaje: I/O Address = 0220, Interrupt level = IRQ 10 a DNA = Channel 1, tak jsem to zkoušel zadávat a nic... :).

11/08/2014 - 20:16
Avatar

Předpokládejme, že zvukovka je kompatibilní se Sound Blasterem - pokud ne, si nahranej a na zvuk pod DOSem zapomeň. Ale mělo by to být OK, kdesi na netu tvrdí, že SB kompatibilní je. A když to tvrdí kdesi na netu, musí to být pravda!

V první řadě zkus, jestli v biosu nejde nastavit nějaké rozumnější IRQ, tedy 5 nebo 7.

Dále do souboru autoexec.bat, který je v rootu na disku, napiš toto: SET BLASTER=A220 I10 D1 (I10 za předpokladu, že IRQ zůstane na 10). Pak to ty samé hodnoty nastav i v konfiguraci dané hry, jako zvukovku vždy vol Sound Blaster Pro a doufej.

11/08/2014 - 20:23
Avatar
Springy

Sledge napsal(a)
Předpokládejme, že zvukovka je kompatibilní se Sound Blasterem - pokud ne, si nahranej a na zvuk pod DOSem zapomeň. Ale mělo by to být OK, kdesi na netu tvrdí, že SB kompatibilní je. A když to tvrdí kdesi na netu, musí to být pravda!

V první řadě zkus, jestli v biosu nejde nastavit nějaké rozumnější IRQ, tedy 5 nebo 7.

Dále do souboru autoexec.bat, který je v rootu na disku, napiš toto: SET BLASTER=A220 I10 D1 (I10 za předpokladu, že IRQ zůstane na 10). Pak to ty samé hodnoty nastav i v konfiguraci dané hry, jako zvukovku vždy vol Sound Blaster Pro a doufej.

Aha, SoundBlaster PRO mi nenapadlo, zkoušel jsem jen SoundBlaster compatible. Proč raději IRQ 5 nebo 7? Nerozhasí to pak zvuk ve windows?

11/08/2014 - 20:25
Avatar

SB compatible / SB pro - on by v tom neměl být rozdíl, takže tady chybu nehledej. Já to vidímna ten set blaster...

5/7 jsou obvyklé hodnoty, 10 už tolik ne, některé hry to mít ani v nastavení nemusí. Wokna se s tim poperou.

11/08/2014 - 20:51
Avatar
Springy

Wokna se S Tím nepopraly... po změně na 5 přestaly  detekovat zvukový adaptér. Možná kdybych je instaloval od znova už s tím IRQ 5, tak by si pak zvukovku našly.

Jinak v tom autoexecu mám jen:

@ECHO OFF

PROMPT $p$q

PATH C:\WINDOWS ;C:\WINDOWS\COMMAND ;C:\DOS

SET TEMP=C:\DOS

mode con codepage prepare=( (852) C:\WINDOWS\COMMAND\ega.cpi

mode con codepage select =852

keyb cz, , C:\WINDOWS\COMMAND\keybrd2.sys

 

Kam mám teda dát ten řádek? 

11/08/2014 - 21:27
Avatar

Kamkoliv za @ECHO OFF, je to jedno.

Pokud se s tim nepopraly, normálně to změň ve wokennim správci nastavení.

11/08/2014 - 22:21
Avatar
Springy

Sledge napsal(a)
Kamkoliv za @ECHO OFF, je to jedno.

Pokud se s tim nepopraly, normálně to změň ve wokennim správci nastavení.

Udělal jsem, jaks mi poradil a zvuk pod DOS jsem rozjel. Zatím sice jen v Jazz Jack Rabbit,  ale jde. Děkuju!

Jinak ale zase všechno není tak ideální a já zřejmě nejsem tak šikovný,  jak jsem si myslel. Zřejmě nefunguje ventilátorek na chladiči CPU. Spodek notebooku se po nějakém čase zahřeje a větrání se nezapne a nezapne. Na druhou stranu ale systém nijak nekolabuje vlivem teploty. i5ka na mém druhém notebooku hřeje víc. Aspoň mám zase nad čím bádat :).

11/08/2014 - 23:29
Avatar
Sany

Dokud noťas nezačne vlivem teploty tuhnout a př. smrdět, je to dobrý :)

Není také vyloučené, že ventilátorek spíná až při vyšší provozní teplotě - u mého Compaqu Evo n610c je např. povolená pracovní teplota procesoru 0 až 100 stupnů Celsia :) A pokud jde o nějaký aspoň trochu standardní větráček s 3 přívody, šlo by ho taky případně zkusit samostatně testnout na ext. 5V PC zdroji...

11/08/2014 - 23:50
Avatar
Springy

Asi ho někdy zkusím otestovat. Tuším, že má jen dva kabely. Je to takovej pidižvýk v hliníkovém tělíčku a podobný, nebo možná stejný tu mám navíc.  A noťas zatím nesmrdí, tak je to asi v cajku. Kde se když tak dá nastavit to spínání větrání? Ten jeho bios je takovej minimalistickej...

12/08/2014 - 08:25
Avatar

Jestli je uvnitř klasický Pentium 100, tak chlazení zaručeně potřebuje. Vydrží toho dost, ale bez ventilátoru bude pod zátěží topit jak peklo samo...

12/08/2014 - 08:46
Avatar
Springy

No nevím jestli klasický penťák. Chladič jsem sice nesundaval, ale ten procesor je asi tak třetinový oproti socket 5/7 procesorům.

12/08/2014 - 08:48
Avatar

V tom případě jednoduchý test: zkus pustit třeba MP3ku a následně na hliníkový chladič, co je na CPU, šáhni - udržíš na něm prst? :)

12/08/2014 - 09:19
Avatar
Prague

Je tam (co jsem vygooglil) Intel Pentium SL Enh, čili nějaká low-power mobilní verze, ta klidně může běžet dlouho pasivně, pak deska sepne na dvě minuty ventilátor a zas se jede pasivně.  Takové notebooky mám osobně nejradši.

12/08/2014 - 09:45
Avatar
Springy

Tak to je super! Budu se muset naučit líp Googlit :). Hlavně že noťas jede i bez baterek. Tu druhou na 7.2V tam cpát nebudu, musel bych si jí nechat vyrobit, třeba u Batexu, a vyšla by mi aspoň na 4kila.

12/08/2014 - 09:55
Avatar
Prague

Nicméně tak či tak ten ventilátor bych testnul, buď ohmmetrem (měl by mít asi vysoký odpor, ale ne nekonečný) nebo zapojením napájení (tipuju 5V, takže klidně z baterie od mobilu, těch 3.7 co mají LiIonky by to mělo bez potíží roztočit).

12/08/2014 - 10:32
Avatar
Springy

Přes baterii od mobilu říkáš? No, zkusím to, ale netuším jak to zapojit. Možná když to zkusím přes 5V větev na AT zdroji, tak tím taky nic nezkazím, ne?

12/08/2014 - 13:01
Avatar
Prague

Pokud je z ventilátoru patrno, že je to 5V ventilátor, tak nic nezkazíš. V notebooku to klidně může být nějaká 3.3V úchylárna a pak pápá ventilátore, 5V ho pošle do křemíkového nebe. 

26/08/2014 - 19:49
Avatar
Springy

Tak CMOS baterie z ebay si dává na čas, škoda.

Nicméně jsem před nedávnem, v návalu nákupní horečky, pořídil 32MB modul. Ani jsem nedoufal, že bude fungovat, ale on funguje :) Teď má Toshiba 40MB RAM (o 16MB víc, než s původním modulem). S tím by už mohly i Win 98 šlapat slušně, ne? :) 

26/08/2014 - 20:10
Avatar
Sany

40MB bude pro W98 v pohodě - jen bacha na to, aby ti nedošlo místo na hardu, viz topic : http://forums.cnet.com/7723-6618_102-41364/how-to-clean-install-win98/

26/08/2014 - 20:22
Avatar
Springy

A nebo tam nechám 5a90ky a třeba nebudou tolik swapovat :). Díky za odkaz!

01/09/2014 - 13:16
Avatar
Springy

Tak 32MB modul zrejmě odešel do křemíkového nebe. Od té doby, co jsem ho namontoval, jsem notebook nezapnul. Včera jsem se ale divil, když se mi hlásilo jen 8MB ram. 16MB modul ale funguje správně, takže chyba nebude na základní desce. Zkusil jsmem pročistit konktor isopropylem, ale modul se stále nehlásí. Škoda,  moc jsme si spolu neužili. Chca - nechca budu muset přejít na Win95. :(

No permission to create posts
Časové pásmo: Europe/Prague

Nejvíce uživatelů online: 351

Právě online:
12 Host(é)

Právě prohlíží tuto stránku:
1 Host(é)

Nejaktivnejší uživatelé:

LubikCZ: 2089

Sany: 1486

MilasPce: 1294

Neny: 1133

Logout: 896

Powerack: 861

Statistiky uživatelů:

Hosté: 14

Členové: 506

Moderátoři: 0

Administrátoři: 1

Statistiky fóra:

Skupiny: 5

Fóra: 24

Témata: 1211

Příspěvky: 20803

Nejnovější uživatelé:

Roman90, Petju von Strom, Appu, Mizu, Hanickaaa5, KlainnCZ, Wirtual, Dr.Watson, Iqtyq, Mira 7474, Roman, Limbo, Flashback, historik Archa, argus

Administrátoři: Sledge: 5159

high-voltage.cz
high-voltage.cz

Retroherní a retrovýpočetní magazín high-voltage.cz vám denně přináší články a novinky ze světa starých her a starého hardware.

Podpořit

1 202 Kč měsíčně

Již přispělo 12 patronů

Pěkně prosím, podpořte svůj (doufám) oblíbený retroherní web drobnou částkou. Každá koruna se počítá a za každou korunu díky! :) Více zde »